Romain Eveillard

Installation et maintenance informatique / Programmation PHP/MYSQL HTML/CSS











bandeau décoratif
Administration réseau / Configuration VLAN routeur Cisco (1941) et switch (2960)

Configuration VLAN routeur Cisco (1941) et switch (2960):


Dans cette exemple, nous allons voir comment mettre en place deux VLAN avec leur DHCP que l'on nommera LAN10 et LAN20.

L'adresse réseau du VLAN10 sera 192.168.10.0/24 et celle du VLAN20 sera 192.168.20.0/24, une exclusion d'une plage ip sur chaque VLAN afin de les réserver pour différent périphérique. (ex:IP du serveur, IP switch, IP d'imprimante ou copieur).

Mise en place de l'encapsulation des VLAN au niveau du routeur, puis nous finirons par le switch en créant les VLAN et en activant le port GigabitEthernet0/1 en mode trunk.


Configuration du routeur (1941)

Router#enable
Router#config terminal
					
  • On active le mode privilégié
  • On rentre en mode configuration globale
Création des deux réseaux avec leur DHCP:
Router(config)#ip dhcp pool LAN10
Router(dhcp-config)#network 192.168.10.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.10.254
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#exit
					
  • Création du DHCP LAN10
  • On créer l'adresse réseau et le mask
  • Déclaration adresse routeur
  • Déclaration DNS
  • On sort du mode (dhcp-config)
Router(config)#ip dhcp pool LAN20
Router(dhcp-config)#network 192.168.20.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.20.254
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#exit
					
  • Création du DHCP LAN20
  • On créer l'adresse réseau et le mask
  • Déclaration adresse routeur
  • Déclaration DNS
  • On sort du mode (dhcp-config)
Exclution d'adresse afin de ne pas avoir de conflit d'ip avec les ip qu'on placera en fixe
Router(config)#ip dhcp excluded-address 192.168.10.250 192.168.10.254
Router(config)#ip dhcp excluded-address 192.168.10.250 192.168.20.254
					
  • Exclusion d'une plage ip sur le réseau 10 pour les réserver, dont une pour le routeur
  • Exclusion d'une plage ip sur le réseau 20 pour les réserver, dont une pour le routeur
Création de la passerelle pour le réseau 10 sur l'interface 0/1 du routeur
Router(config)#interface GigabitEthernet0/1.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.10.254 255.255.255.0
Router(config-subif)#exit
					
  • mode de configuration GigabitEthernet0/1.10 pour l'encapsulation
  • On encapsul le VLAN10 sur l'interface 0/1.10
  • On donne l'ip et le mask de l'interface 0/1.10
  • On quitte le mode interface 0/1.10
Création de la passerelle pour le réseau 20 sur l'interface 0/1 du routeur
Router(config)#interface GigabitEthernet0/1.20
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 192.168.20.254 255.255.255.0
Router(config-subif)#exit
					
  • mode de configuration GigabitEthernet0/1.20 pour l'encapsulation
  • On encapsul le VLAN20 sur l'interface 0/1.20
  • On donne l'ip et le mask de l'interface 0/1.20
  • On quitte le mode interface 0/1.20
Configuration de la passerelle pour le réseau 1 sur l'interface 0/1 du routeur
Router(config)#interface GigabitEthernet0/1
Router(config-if)#ip address 192.168.1.254 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
					
  • mode de configuration GigabitEthernet0/1
  • On donne l'ip et le mask à la carte 0/1 du routeur
  • On active la carte 0/1
  • On quitte l'interface config 0/1
Router(config)#exit
Router#write
				
  • On quitte le mode configuration globale
  • On sauvegarde la config

Configuration du switch (2960)

Switch>enable
Switch#vlan database
					
  • On active le mode privilégié
  • On rentre dans la base de donnée des VLAN
Création des VLAN sur le switch
Switch(vlan)#vlan 10 name vlan10
Switch(vlan)#vlan 20 name vlan20
					
  • Nomage du VLAN10
  • Nomage du VLAN20
Paramétrage de chaque port en fonction du VLAN qui lui est affecté
Switch#config terminal
Switch(config)#interface FastEthernet0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
					
  • On rentre en mode configuration globale
  • mode de configuration FastEthernet0/1
  • On passe le port en mode access
  • On lui indique l'access au vlan10
  • On quitte le mode interface FastEthernet0/1
Switch(config)#interface FastEthernet0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
					
  • mode de configuration FastEthernet0/2
  • On passe le port en mode access
  • On lui indique l'access au vlan10
  • On quitte le mode interface FastEthernet0/2
Switch(config)#interface FastEthernet0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
					
  • mode de configuration FastEthernet0/3
  • On passe le port en mode access
  • On lui indique l'access au vlan20
  • On quitte le mode interface FastEthernet0/3
Switch(config)#interface FastEthernet0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
					
  • mode de configuration FastEthernet0/4
  • On passe le port en mode access
  • On lui indique l'access au vlan20
  • On quitte le mode interface FastEthernet0/4
Paramétrage en mode TRUNK cette fois-ci afin de laisser passer toutes les trames jusqu'au routeur
Switch(config)#interface GigabitEthernet0/1
Switch(config-if)#switchport mode trunk
Switch(config)#exit
Switch#write
					
  • mode de configuration GigabitEthernet0/1
  • On passe le port en mode trunk
  • On quitte le mode interface GigabitEthernet0/1
  • On sauvegarde la config
Une fois la configuration en place, vous devriez sans problème pouvoir "pinguer" les machines entre elles (il n'y a pas de filtrage par défaut).
Nous verrons le filtrage dans un prochain article.
Ce tuto a été réalisé sur du matériel Cisco à l'aide du logiciel Packet Tracer disponible sur www.netacad.com  

© Romain Eveillard 2020